WordPress SEO Plugin Probleme

Ich hab mir neulich das All-in-one SEO Pack von Uberdose für WordPress installiert. Eine schöne Sache eigentlich. Primär gefällt mir daran, dass z.B. der Title ohne große Templateänderungen angepasst wird.

Leider führt das bei mir zum Problem, dass ich beim Speichern/Veröffentlichen eines Beitrags nur eine leere/weiße Seite erhalte und auch keine Pings rausgeschickt werden.

Hat jemand eine Idee woran das liegen könnte? Andere Plugins hab ich probiert, aber bisher hat mir keines so gut gefallen.

12 Gedanken zu „WordPress SEO Plugin Probleme“

  1. Ich setze auf meinem Blog (WP 2.1.3) All-in-one SEO Pack ein, und es gab absolut keine Probleme. Auf einem anderen Blog teste ich gerade wpSEO aus. Es gefaellt mir eigentlich besser als A-i-o SEO, vor allem kannst du meiner Meinung nach die Meta-Tags besser deinen Wuenschen nach anpassen. Das einzige worauf du achten musst, da hast du recht, ist dass die Meta-Tags nicht bereits in deinem Template enthalten sind, sonst ueberschreiben sie sich natuerlich. Wenn du diese aber rausnimmst, klappt das mit dem wpSEO absolut spitzenmaessig. Ich denke, ich kann wpSEO nur empfehlen!

  2. Hi Frank,

    falls Du Dich noch erinnern kannst. Ich hatte doch auch ein Ping Problem bei meinem Blog. Die Ursache war wpSEO in Verbindung mit Simple Tagging. Für wpSEO ist es wichtig, dass kein anderes Plugin die Meta-Einträge beeinflusst und ich hatte versäumt eine der Meta-Einstellungen bei Simple Tagging zu entfernen. Vielleicht gibt es ähnliche Wechselwirkungen mit dem All-in-one SEO Pack. Ich würde einfach mal alles rausnehmen was sonst noch im Header rumwerkelt.

  3. Hi Nils,

    danke für den Tipp – ich schau’s mir mal an.

    Frank

    EDIT: Danke für den Tipp. Es lag zwar nicht direkt an Simple Tagging, aber ich hatte noch ein anderes Plugin aktiv, dass ich gar nicht mehr gebraucht habe, das saber den Header manipuliert hat. Das war das Problem.

  4. Tagchen.

    Ich bin der Entwickler des wpSEO-Plugins und wollte paar Zeilen dazu schreiben :)

    Hab mir den All-in-one SEO Pack angeschaut. Ich will jetzt nicht sagen, ob dieses Plugin besser oder schlechter ist als wpSEO, (Anzahl der Funktionen spricht schon für sich) eins steht doch fest: Beide Plugins schreiben die META-Tags in die Seite nach dem gleichen Prinzip. Der Unterschied: Aus Erfahrung weise ich als Entwickler die Nutzer darauf hin, dass bereits META-Tags existieren KÖNNTEN, müssen aber nicht. Und da kann auch so bestes Plugin nichts ändern, da WordPress einfach keine technische Möglichkeiten zur Prüfung – ob bestimmte Tags gesetzt sind – zur Verfügung stellt.

    wpSEO geht sogar schon soweit und erkennt, ob META-Tags von Simple Tagging bereits gesetzt sind und weist darauf hin – welches Plugin macht es noch, All-in-one SEO Pack vielleicht?

    Anderes ist es tatsächlich bei dem TITLE: Da überschreibt er den vorhandenen Titel der Seite. Doch der Ansatz hat einen Hacken! Erstens ist es überhaupt nicht sichergestellt, dass ein Titel zum Überschreiben bereits vorhanden ist (In meinem Blog hat All-in-one SEO Pack leider nicht geschafft den Titel zu setzen, da ich einfach keinen manuellen gesetzt hatte). Zweitens wird der von WordPress gestartete Buffer umgeschrieben, was ich für eine unsaubere Lösung halte. Meine Theorie: Lieber einmal manuell anpassen, als jedesmal dynamisch vom Script umschreiben lassen.

    Und seien wir mal ehrlich: Haben wir unser Blog auf die Beine gestellt, ohne ein eigenes Template anzupassen? WordPress stellt sogar einen Dateieditor zur Verfügung! Und einmal im Template nachschauen und eine Zeile auskommentieren schafft doch auch jeder Einsteiger – man muss ihm nur zeigen wo und wie. Und das erledigt wpSEO mit Bravour.

  5. @#2
    also im template muss man wirklich nicht viel rumfummeln ;-) einfach nur das entfernen oder
    auskommentieren und das wars schon. selbst ein anfänger schafft das mit der anleitung auf wpseo.de. wpseo gehört zu den top seo plugins für wordpress

  6. @Frank
    Habe jetzt testweise auch mal den All-in-one-SEO-Pack installiert. Hatte leider mit WP-Seo ein Umlautproblem in den Keywords und der Discription.

    Ist es sinnvoll beim AIO-Seo-Pack bei den Optionen alles zu aktivieren (noindex….)? Hast Du hierzu vielleicht einen Erfahrungswert?

  7. hallo frank,
    hab aktuell mit meinem blog und wpseo dasselbe problem. kannst du bitte kurz skizzieren was das problem schlussendlich behoben hat? gerne auch per mail. danke!

Kommentar verfassen